Today I rebuilt my boot disk using advice from several people on this
list combined with information in the Tru64 documentation. There's a
section in the AdvFS administration document that was particularly
useful. I thank
Bluejay Adametz
alan
Cory Erickson
Simon Millard
Dr Thomas Blinn
Timothy Brown
Greg Freemyer
John Galt
I was able to install a new boot disk and restore my system without any
major problems, although I did run into a couple of quirks. Here is the
procedure I used (cleaned up a bit to make it sound more straightforward
than it actually was):
+ I installed the disk. It was a SCSI device with about size the
capacify of the original.
+ I booted the installation CD and at the first "normal" window,
selected "Shell Window" from the File menu. This brought up an
interactive prompt.
+ I used "hwmgr -view devices" to see if the new disk was recognized. It
was. I noticed that it was shown as "dsk0".
+ I created a "standard" disklabel on the new disk using
# disklabel -wr -t advfs /dev/rdisk/dsk0c
I had to indicate the AdvFS type since I wanted to rebuild my AdvFS
domains (all file systems on the previous system were AdvFS including
the root file system).
+ I then read back the disklabel with the "-r" option and saw that some
of the partition sizes were not to my liking. I used the "-e" option
to edit the disklabel into something more suitable. NOTE: the root
domain *must* be on the 'a' partition. If it is not, the SRM boot code
will not be able to locate the osf_boot file.
+ I used "dn_setup -install_tape" to make the tape drive available. I
verified this with "hwmgr -view devices".
+ I created my file domains and file sets.
# mkfdmn -r /dev/disk/dsk0a root_domain
# mkfdmn /dev/disk/dsk0h usr_domain
# mkfset root_domain root
# mkfset usr_domain usr
# mkfset usr_domain local
+ I restored my files.
# mount root_domain#root /mnt
# vrestore -v -x -f /dev/ntape/tape0 -D /mnt
# umount /mnt
# mount usr_domain#usr /mnt
# vrestore -v -x -f /dev/ntape/tape0 -D /mnt
# umount /mnt
# mount usr_domain#local /mnt
# vrestore -v -x -f /dev/tape/tape0 -D /mnt
I used the "ntape" device because on my last backup (level 0) the
various file sets are loaded back-to-back on the tape. Thus I did not
want to rewind after the first two file sets.
+ Now.. because I put my rebuilt usr_domain on a different partition
than on the original system (making this needlessly complicated) I had
to remount my new root_domain and do
# cd /mnt/etc/fdmns/usr_domain
# ln -s /dev/disk/dsk0h dsk0h
# rm dsk0g
The old partition was dsk0g.
+ Finally I halted the system with "halt", checked the bootdef_dev
environment variable in the SRM console, and did
>>> boot -fl s
to bring the system up in single user mode for inspection.
When the system started I used "bcheckrc" to mount all file systems and
I encountered problems with /usr and /usr/local. It turned out that the
system had renamed my disk from dsk0 to dsk2. I thus had to change the
links in /etc/fdmns/usr_domain and /etc/fdmns/root_domain. I also had to
edit /etc/sysconfigtab to change the location of the swap partition from
/dev/disk/dsk0b to /dev/disk/dsk2b. I restarted the system again and all
was well.
Received on Wed Sep 18 2002 - 17:59:25 NZST