Subject:Problem with installation of the Qlogic 1024
Results:
As suggested, a rebuild of the kernel solved the problem. I was under the
assumption that Digital Unix 4.0d would find the interface and dynamically
load the driver support in the kernel. It worked when I tested it out on the
box at my desk...It was running Tru64 5.0. I was also fooled by the fact
that it will find new drives. Here are the steps performed to fix the
problem.
as root:
1. copy /vmunix to /vmunix.0617 (always play safe)
cp /vmunix /vmunix.0617
2. verify that the generic kernel was still there...
find / -name genvmunix
If not you will have to rebuild using the GENERIC config
3.shutdown the box...
shutdown -h now
4.reboot using the generic kernel.
boot -fi "genvmunix"
My system came up with all filesys mounted.
5.create new target file
sizer -n MYSYS
MYSYS is the name of the system in caps
6. the new target file is in /tmp
7. find the differences between your old config
and the one created by sizer.(the config's are
in /usr/sys/conf)
diff /tmp/MYSYS MYSYS
the manual suggested the diff command I
found that printing out the two was easier to
read.
8. Found the three lines that added support
for my card.
bus pci2001 atpci1 slot 4
bus isp1 atpci2001 slot 0 vector ispintr
controller scsi2 at isp1 slot 0
9. added the above lines to my /usr/sys/conf/MYSYS
except I changed scsi2 to scsi3 so that I wouldn't
change the existing dev files..I left the scsi drives
on thier original scsi bus.
10. performed a kernel rebuild
/usr/sbin/doconfig -c MYSYS
11. move the kernel in place
mv /usr/sys/MYSYS/vmunix /vmunix
12. rebooted the box using the new kernel
shutdown -h now
boot
Thanks for all of the support. Here is a list of the responders that helped
out
alan_at_nabeth.cxo.dec.com
Davis_at_tessco.com
rye_at_jwfc.jfcom.mil
Kevin.Partin_at_SW.Boeing.com
oisin_at_sbcm.com
SEB_at_LNS62.LNS.CORNELL.EDU
and anyone I may have left out
Thanks all,
Lee Brewer
Received on Tue Jun 20 2000 - 18:16:10 NZST